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Accessibility


Student name:_________________________________________________ Date: ________________________


URL: ________________________________________________________________________________________


Site name: ____________________________________________________________________________________


Do the images have alternative text so screen readers can read the description?


Are all the links, including embedded links, labeled so they can stand alone?


Do data tables have header rows or header columns?
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Are there clear titles and headings that help organize the information for someone using a screen reader?


Is the navigation scheme positioned conveniently for someone using a screen reader?


Is color the only element used to convey emphasis?





		Accessibility
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Analyzing websites


Student name:_________________________________________________ Date: ________________________


URL:________________________________________________________


Site name:____________________________________________________


Category: ____________________________________________________


Visual Layout


Describe the visual elements on the home page. What caught your eye first?


How does the graphic design (balance, emphasis, color, tone, visual hierarchy, and so on) communicate the content?


If there are images on the page, do they add value to the content, or are they for decoration and appeal? If they add 
value, describe how.
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How quickly did the page draw? Was it worth the wait?


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


How well does the layout of text help viewers understand the main points of the site content? Does the text layout and 
style follow an appropriate visual hierarchy? If so, how does the visual hierarchy help viewers understand the 
content? 


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


Consistency Structures


Are any of the elements repeated on subsequent pages? Are the elements decorative or part of the navigation? 


Does the repetition help or hinder the overall purpose of the website? 
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How consistent is the placement of the navigation scheme? 


How consistent is the use of color? 


How consistent are fonts and font sizes? In what ways do the text styles vary?


Color Scheme


Does the color scheme add to the purpose or tone of the site?
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How does the color scheme help or hinder in conveying the purpose of the site?


Content Bias


Can you tell why the site was created? Is there an organization associated with the site, and if so, what type of 
organization? 


Is it clear which portions of the site’s content are fact and which are opinion?


Is there any bias in the information presented? Is there a hidden purpose?
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Content Currency


When was the information first placed on the page?


When was it last revised?


Are there any other indications that this information is current? What is the quality of the related links?


Content Source


Who is responsible for this site?
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What qualifications or expertise does the author have to write about the topic on this site?


Is there a way to verify the legitimacy of the author, such as an e-mail address, phone number, or mailing address?


Who sponsors this site? Has the site been reviewed or won any awards?


What is the domain extension of the site? What does this extension tell you about the site?
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Content Corroboration


What other sites have information on this topic?


Is the information the same?


Are these other sources valid?
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Creating consistent content pages
Content pages link from the web portfolio’s home page. Using the ideas from the class discussion, determine the 
consistent elements of your content pages and plan your navigation bar. Create a checklist of items that will appear on 
each page by answering the following questions. Then create a wireframe for the general layout of a content page, 
drawing and labeling the elements that will appear on all content pages.


Organizing content


How you organize content on a page highlights important features and elements of your site. Important elements 
might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, copy 
layout, graphic allocation, key headers, and other elements that appear on a screen. Identifying common structures 
between pages helps visitors understand they are in the same site as they navigate from page to page.


• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?


• What font will you use for titles or headings on your content pages?


• What color will you use for titles or headings on your content pages?


• What font will you use for descriptions on your content pages?


• What color will you use for descriptions?


Navigation


For visitors of your website to understand the content, you must provide clear navigation. Visitors need to know 
where they are in a site, where they need to go, and how to get back to where they came from. Having a consistent 
layout grid helps orient visitors and keeps them from feeling lost. Using consistent buttons, links, and graphics on 
each page maintains a sense of place. As visitors move from page to page, provide familiar visual cues and 
navigational aids.


Here are some questions to answer:


• Where will you place the navigation bar on the page?


• What content will be on the navigation bar?


• Will the navigation bar be on every page?


• How will your navigation bar help visitors know which page they are on?





		Creating consistent content pages

		Organizing content

		Navigation
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CSS Styles panel
Use the CSS Styles panel to create, view, apply, or edit CSS styles for elements of a web page. In the All mode, the 
panel has two panes: All Rules and Properties.


Select a style to apply to 
the selected text in your 
document or to examine 
and edit the rules for that 
style.


Show Category View: 
View the properties of a 
style rule by property 
category.


Show List View: View an 
alphabetical list of 
possible properties and 
those that compose the 
selected style rule.


Show Only Set Properties: 
View a list of properties 
that compose the selected 
style rule.


Attach Style Sheet: Attach 
an external style sheet to 
your current document.


New CSS Rule: 
Create a new style 
rule.


Edit Style Sheet/Edit Rule: 
Make changes to the 
selected style sheet linked 
to the document or to the 
selected style.


Unlink CSS Stylesheet/ 
Delete CSS Rule: Unlink 
the selected style sheet 
from the document or 
remove a rule from a style 
sheet. When you unlink 
style sheets and delete 
rules, all the formatting 
associated with the style 
sheet or rule is removed.


Disable/Enable CSS Property: 
Temporarily disable/enable the 
selected property.
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In the Current mode, the panel has three panes: Summary For Selection, Rules, and Properties.


The Properties pane 
allows you to edit the 
rule’s properties and add 
new properties.


The Rules pane either 
displays all rules for the 
selected tag (as shown) or 
the name and file location 
of selected properties, 
depending on your 
selection.


The Summary For 
Selection pane displays 
the CSS properties for the 
current selection in the 
document.





		CSS Styles panel
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CSS Styles panel


Student name:_________________________________________________ Date: ________________________


Use the CSS Styles panel to create, view, apply, or edit CSS styles for elements in a web page. In the All mode, the 
panel has two panes: All Rules and Properties. Use the All Rules pane to apply styles to your document and the 
Properties pane to edit existing properties and add new properties to the selected style.


Label the options available for creating and editing Cascading Style Sheets.





		CSS Styles panel
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File list
You may have some or all of the following documents:


• Text document with images from the web (Unit 1)


• Web search images (Unit 1)


• Scanned images (originals)


• Text document that contains annotated notes for the scanned images (Unit 1)


• Digital camera photographs (Unit 1)


• Text document that contains annotated notes and photographs (Unit 1)


• Optimized GIF and JPEG images (Unit 1)


• Nameplate (Unit 1)


• Nameplate interview (Unit 1)


• Logo storyboard (Unit 1)


• Logo (Unit 1)


• Logo redesign (Unit 1)


• Page banner storyboard (Unit 1)


• Page banner (Unit 1)


• Page banner redesign (Unit 1)


• Technical test plan document (Unit 2)


• Technical test outcome document (Unit 2)


• Usability test plan document (Unit 2)


• Usability test outcome document (Unit 2)


Other files your class created:





		File list
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Overview of the Adobe Dreamweaver CS5 workspace
You can access Adobe Dreamweaver CS5 tools, commands, and features by using menus or by selecting options 
from one of the Insert panels or from Dreamweaver panels. The most commonly used areas of the Dreamweaver 
interface (Figure 1) are the Document window, the Insert panel, the panels, and the Property inspector.


The Document window displays the current document as you create and edit it. The Insert panel contains buttons for 
creating and inserting objects such as images, tables, layers, and frames you might want to add to your web pages. 
The Property inspector displays properties for the selected object or text and lets you modify those properties. 


The Document window and panels


You can add and manipulate text, images, menus, tables, and other elements in the Document window, and it displays 
an approximate representation of your web page.


Figure 1 Dreamweaver interface


Switching between views


Dreamweaver lets you work in a variety of views. Lay out a page graphically in Design view, work directly with the 
underlying code, split the screen into both Code and Design views, or edit in Live view which lets you see a non-
editable browser-based rendering of the document as you create and edit it. Change views by using the view buttons.


• Code view lets you view and edit the HTML, CSS, JavaScript and other code of which the current page is 
constucted.


• Design view lets you edit and view the page roughly as it will appear in a browser.


• Code and Design view (Split view) lets you see both Code view and Design view simultaneously. 


View buttons Property inspector


Document
window


Files 


Assets 
panel


panel 


Insert panel


Document 
toolbar
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There are also two additional views related to code that dynamically changes the page--that is, code that will change 
as users interact with the page:


• Live view lets you view the page’s design as it will appear when users interact with it in a browser. Live view is 
not editable. However, you can edit in Code view and refresh Live view to see your changes.


• Live Code view lets you view a page’s code as it will appear when users interact with it in a browser. This view is 
available only when viewing a document in Live view. Live Code view is not editable.


To switch between views, click their buttons in the Document toolbar (Figure 1).


Dreamweaver workspaces


You can also manage panels by using workspaces. Workspaces are pre-arranged panel settings optimized for specific 
tasks or work styles. 


To switch between workspaces:


1. Select a new workspace from the workspace switcher in 
the Application bar (Figure 2), such as the Designer 
Compact workspace.


The panels are rearranged.


Figure 2 Workspace switcher


To create a new workspace:


1. Make changes to an existing workspace, such as by 
opening new panels or closing open panels.


2. Choose Window > Workspace Layout > New Workspace.


The New Workspace dialog box (Windows) or Save 
Workspace dialog box (Mac OS) opens (Figure 3).


3. Enter a name for the new workspace.


4. Click OK.


The workspace is now available in the workspace 
switcher.


Figure 3 New Workspace dialog box


Panels


Depending on the selected workspace, the right side of the workspace displays panels. 


Panel groups


Panels are often arranged into panel groups. Panel groups are panels that are docked together. For example, the Files 
and Assets panels are docked together by default in the Designer workspace (Figure 4).


Figure 4 Panel group
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• To move a panel into a group, drag the panel’s tab to the highlighted drop zone in the group.


• To rearrange panels in a group, drag a panel’s tab to a new location in the group.


• To remove a panel from a group so that it floats freely, drag the panel by its tab outside the group.


• To move a group, drag the title bar (the area above the tabs).


Working with Panels


• Opening and closing panels:To open a panel, select it from the Windows menu. To close a panel, do one of the 
following:


◦ Click the Close button at the top of the panel.


◦ Select the panel in the Windows menu.


• Moving panels and panel groups. To move a panel, drag it by its tab. To move a panel group or a stack of floating 
panels, drag the title bar.To dock a panel, drag the panel until the border changes to blue. Release the mouse to 
dock the panel. To undock the panel, drag it away from the left border.


• Minimizing or maximizing panels: To minimize or maximize a panel, double-click the tab bar or the tab area (the 
empty space next to the tab).


• Collapsing panels: Collapsing a panel makes it available as an icon (Figure 5). To collapse or expand a panel, do 
one of the following:


◦ Click the double arrow in the panel's title bar.


◦ Double-click the title bar.


• Docking and undocking panels: As you move panels, you see blue highlighted drop zones. Drop zones are areas 
where you can dock the panel. If you drag to an area that is not a drop zone, the panel floats freely in the 
workspace.


• Resizing panels: To resize a panel, drag either its left or bottom border. All panels have a minimum size beyond 
which they cannot be minimized. Panels can be maximized to fill your screen.


Figure 5 Collapsed panel


Commonly used panels


One of the most frequently used panels is the Files panel. This panel displays the organization of your site and lets 
you open files for editing, publish files to a server, or delete files.


Another frequently used panel is the Assets panel. This panel provides two ways to view site assets. Site assets are 
elements used in a site, such as images, colors, or movies.


The Assets panel provides two ways to view assets:


• The Site list shows all of the assets in your site.


• The Favorites list shows only the assets you’ve chosen to include in the Favorites list.


Collapse To Icon button


Title bar
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The Insert panel


The Insert panel contains buttons for inserting various types of objects, such as images and tables, into a document. 
The Insert panel contains several categories, such as Common and Layout. 


Common category in the Insert panel 


The Common category in the Insert panel (Figure 6) contains buttons for inserting the most commonly used objects.


Hyperlink: Insert a hypertext link.


Email Link: Insert a link to an e-mail address.


Named Anchor: Insert a link to a specific location on a page.


Horizontal Rule: Insert a horizontal rule to visually separate sections on a page.


Table: Insert a table.


Insert Div Tag: Insert a div tag used for page layout.


Images: Insert an image.


Media: Insert media objects, such as Flash, Shockwave, Applets, and ActiveX.


Widget: Insert a Dreamweaver widget.


Date: Insert the current date, with an option for automatic updating when you save the document.


Server-Side Include: Use as a placeholder for commonly used code that can be reused by many pages in your site. 
When you use a SSI file the server takes the entire content of the file stored on a server and inserts it into the page, 
replacing the include code.


Comment: Insert a comment, which will not be displayed on your web page.


Head: Insert keywords, meta tags, page descriptions, and other document data that is kept in the page’s head tag.


Script: Insert or remove script, such as Javascript.


Templates: Make a template based on the current document.


Tag Chooser: Insert an HTML tag.


Figure 6 Common category in the Insert panel
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Layout category in the Insert panel 


From the Layout category in the Insert panel (Figure 7), you can insert tables and choose between two modes. 
Standard mode displays a table as a grid of lines. Expanded Tables mode adds cell padding and spacing to tables and 
increases table borders to make editing easier. 


Insert Div Tag: Insert a div tag to create a content block.


Draw AP Div: Insert an absolutely-positioned div tag to hold content at a specific location on the page.


Spry Menu Bar: Insert a set of navigational menu buttons that display submenus when a site visitor hovers over one 
of the buttons.


Spry Tabbed Panels: Insert tabs that a site visitor can click to reveal hidden content.


Spry Accordion: Insert a set of collapsible panels that can store a large amount of content in a compact space.


Spry Collapsible Panel: Insert a panel that can hide or reveal a large amount of content when a site visitor clicks the 
tab of the panel.


Table: Insert a table.


Insert Row Above: Insert a row above the current row in a table.


Insert Row Below: Insert a row below the current row.


Insert Column to the Left: Insert a column to the left of the current column.


Insert Column to the Right: Insert a column to the right of the current column.


IFrame: Insert a content block in which the browser displays a separate HTML document. 


Frames: Insert a frame.


Figure 7 Layout category in the Insert panel
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The Property Inspector


In the Property inspector, you can view and change a variety of properties for the currently selected object or text. 
Each kind of object has different properties. Figure 8 shows the Property inspector for a selected table. It displays 
column and row attributes, cell colors, and border colors. You can change cell padding (the amount of space between 
the cell content and cell walls) and cell spacing (the amount of spacing between table cells) as well. When you select 
text, you can alter font, size, color, and alignment in the Property inspector.


Figure 8 Property inspector
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File management folders


Student name:_________________________________________________ Date: ________________________





		File management folders
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File management


Student name:_________________________________________________ Date: ________________________


Part I


As you create a file management strategy, describe the method you use by answering the following questions:


Questions


How are you categorizing the files?


How does your file organization help you find particular 
files?


How easy to understand are your file and folder names?


File management notes


--------------------------------------------------------------------
-                                                                                            







Activity 2.4 worksheet Digital Design


2 File management © 2010 Adobe Systems Incorporated


Part II


Write the name of the file you are searching for, its content, and the location in which you found it. Then answer the 
questions that follow.


Example:


Filename: carrot.gif


File content: science


File location: john_doe/science/images/carrot.gif


Filename: ____________________________________


File content: __________________________________


File location: _________________________________


Was it difficult to find this file? Why or why not?


Was the file located in a folder you expected? If not, 
where did you expect the file to be located?


Did the names of the folders and files make sense to 
you? Why or why not?


Filename: ____________________________________


File content: __________________________________


File location: __________________________________


Was it difficult to find this file? Why or why not?


Was the file located in a folder you expected? If not, 
where did you expect the file to be located?


Did the names of the folders and files make sense to 
you? Why or why not?
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Fireworks panels


Floating and docked panels


Panels provide easy access to controls that help you edit selected objects or elements of a document in Adobe 
Fireworks CS5. You can use panels to work on frames, layers, symbols, color swatches, and more. Each panel can be 
dragged, so you can group panels together in custom arrangements. By default, the panels are docked to the right side 
of the workspace. You can undock panel groups, add panels to a group, undock individual panels, rearrange the order 
of docked panel groups, and collapse and close panel groups. To undock a panel, drag the panel gripper in the upper 
left corner of the panel's title bar. Many of the panels are tabbed, with two or more panels combined.


Tools panel


The Tools panel (Figure 1) is organized into clearly labeled sections for easy tool selection. If the Tools panel is not 
visible, you can display it by selecting Window > Tools. To select a tool, just click it or use the shortcut key shown in 
parentheses. If a tool has a small black triangle in the bottom right corner, it is part of a group of tools; move the 
pointer to the tool, and then click and hold down the mouse button to access the pop-up tool group.
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Figure 1 Tools panel


View tools:


Three top icons: Standard Screen mode, Full 
Screen With Menus mode, or Full Screen 
mode.


Hand tool: Move the visible portion of an 
image without using the document scroll 
bars.


Zoom tool (magnifying glass): Zoom in or 
out for a closer or farther view of an image.


Interactive objects tools:


Rectangle Hotspot tool: Draw a special area 
on top of an image that can be clicked to link 
to a new web page.


Hide Slices And Hotspots: Hide all slices and 
hotspots drawn on an image.


Slice tool: Draw slice areas on an image to 
enable user interaction with the image on a 
web page.


Show Slices And Hotspots: Show all slices 
and hotspots drawn on an image.


Selection, movement, and transformation 
tools:


Pointer tool (black arrow): Click an object to 
select it. Drag a selected object to move it.


Scale tool: Enlarge or reduce an object, 
rotate, flip, distort, or skew objects or 
groups.


Subselection tool (white arrow): Select and 
move points of an object or edit paths 
between adjacent points.


Crop tool: Remove the part of an image 
outside a selected rectangular region.


Drawing and writing tools:


Line tool: Draw straight lines.


Rectangle tool: Draw rectangles. Click and 
hold the small arrow at the bottom right to 
select a different shape to draw.


Freeform tool: Draw freeform shapes.


Pen tool: Click to place points; the Pen tool 
connects successive points with straight lines. 
Drag a point to form a curve.


Text tool: Type text.


Knife tool: Cut a path in two or more paths.


Image modification tools:


Marquee tool: Select a rectangular region of 
pixels. Press and hold the small arrow at the 
bottom right to select a different shape for your 
selection tool.


Magic Wand tool: Select pixels of a similar 
color.


Pencil tool: Draw a bitmap line with a 1-pixel 
stroke.


Blur tool: Blur the focus of parts of an image.


Lasso tool: Similar to Marquee tool, but lets 
you freeform-select an area of pixels.


Brush tool: Select from a variety of brush 
strokes, such as spray paint, calligraphy, 
crayon, and air brush.


Eraser tool: Erase parts of an image.


Rubber Stamp tool: Duplicate an area of an 
image.


Color tools:


Eyedropper tool: Sample a color from existing 
pixels. You can sample a 1-pixel, 3-by-3, or 5-
by-5 pixel area. The sampled color appears in 
all Stroke Color or Fill Color boxes 
throughout Fireworks. 


Paint Bucket tool: Change the color of 
selected pixels.


Stroke Color box: Set the color of the outline 
of an object.


Fill Color box: Set the color of the region 
inside an object.


Three bottom icons:


Set Default Stroke/Fill Colors: Automatically 
set colors for stroke and fill; defaults are black 
for stroke and white for fill.


No Stroke Or Fill: A white box with a red line 
means there is no color (completely 
transparent). You cannot modify a stroke or 
fill with no color.


Switch Stroke/Fill Colors: Swap the stroke 
and fill colors.
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Property inspector


The Property inspector displays options that change according to the current object or tool selection. Open a 
document, and the Property inspector displays document properties. Select a tool, and it displays tool options. Select 
a vector object, and it displays options such as stroke and fill. You can change these and other options right from the 
Property inspector. By default, the Property inspector is visible, but you can hide or show it by selecting Window > 
Properties. The following examples show the properties for a text object (Figure 2) and a rectangle shape (Figure 3). 
The options vary depending on the type of object or tool you have selected.


Figure 2 Text Property inspector


Figure 3 Rectangle shape Property inspector


The first area on the left side of the Property inspector provides information about the selected object. You can also 
use this area to size or position the object on the canvas.


Fill area: Change the fill color of a shape by clicking the color box in the second area of the Property inspector. You 
can select the fill type for a shape, such as solid, patterned, or dithered, from the menu beside the color box. This 
menu also provides various gradient effects. Other options include changing the type and amount of texture.


Stroke area: Change the stroke category or color of a shape in the third area of the Property inspector. Change the tip 
size (thickness of the stroke) by typing a number in the text box beside the color box or by clicking the down arrow 
and then setting the slider. Select the stroke category, such as pencil, felt tip, or crayon, from the last menu on the 
right of the stroke area. Other options include changing the edge softness, the type and amount of texture, and the 
degree of corner roundness.


Filters area: Add effects to objects by clicking the Add Live Filters button (the plus sign) in the last area on the right 
of the Property inspector. You can add filters to either the inside or the border of objects. Filters include glows, 
shadows, bevels, and color adjustments. Delete existing filters by selecting the filter and clicking the Delete Current 
Selected Live Filter button (the minus sign). After you select a filter from the menu, you can vary the opacity and 
blend mode.
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Fireworks tools


Student name:_________________________________________________ Date: ________________________


The Tools panel in Adobe Fireworks CS5 contains the main tools to create and modify images.


Identify the selection, movement, and         
transformation tools:


Identify the image modification tools:


Identify the drawing and writing tools:


Identify the interactive objects tools:


Identify the color tools:


Identify the view tools:





		Fireworks tools










Adobe Dreamweaver CS5 Activity 2.7 guide


© 2010 Adobe Systems Incorporated How to add text from another document 1


How to add text from another document


Copying text from another document


One way to add text to a Dreamweaver document is to copy and paste text from another document.


To copy text from another document:


1. Open the document from which you want to copy text.


2. Select the text and select Edit > Copy.


3. Start Adobe Dreamweaver CS5.


4. Open the Dreamweaver document in which you want to 
paste the text.


5. Position the insertion point in the page where you want to 
paste the copied text.


6. Select Edit > Paste.


The new text appears in the Dreamweaver document.


Note: Copied text may lose some of its original 
formatting, including line breaks and paragraph breaks. 
To insert a blank line after a section of text, position the 
insertion point at the end of the last text line and press 
Enter (Windows) or Return (Mac OS). To create a line 
break at the insertion point, press Shift+Enter (Windows) 
or Shift+Return (Mac OS).


7. To change the format of any new text in the document, 
select the text and apply a CSS rule or create a new CSS 
rule based on the format of the new text.


Importing Word HTML


HTML pages created in Microsoft Word have elements that need to be cleaned up before you can work with these 
pages in Dreamweaver.


To clean up Word HTML:


1. In Dreamweaver CS5, select File > Open.


The Open dialog box opens.


2. Navigate to and select the HTML file you want to open, 
and click Open.


The Word HTML file is opened in Dreamweaver.


3. Select Commands > Clean Up Word HTML.


The Clean Up Word HTML dialog box opens (Figure 1).


4. Click OK.


A summary of the cleanup process appears.


5. Click OK.


Use the Property inspector to edit the text as necessary. Figure 1 Clean Up Word HTML dialog box
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How to check links


Testing links


A key technical testing task is to check all the links in your site. Adobe Dreamweaver CS5 lets you do this 
automatically by using the Link Checker.


To check links:


1. Start Dreamweaver.


2. Make sure your site is open.


3. On the menu bar, select Site > Check Links Sitewide.


The Link Checker tab displays all the broken links in the site (Figure 1).


Note: Even though links are listed as broken, check them in the browser to confirm.


Figure 1 Link Checker tab


4. Fix the broken links and check the links again.


Note: To clear the current Link Checker results, select Clear Results from the Link Checker Options menu.


Link Checker Options menu
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How to create buttons and navigation bars
Adobe Fireworks CS5 enables you to design the look and functionality of buttons, including links and rollover 
features. After you export these buttons from Fireworks, you can import them into Adobe Dreamweaver CS5.


Building a button


In the following steps, you create a button for export into Dreamweaver.


To build a button:


1. Start Fireworks. Create a new document. Type 200 pixels for Width and 200 pixels for Height. Type 72 pixels/
inch for Resolution.


Note: At the end of this exercise, you will trim the canvas to fit the button. 


2. Save the document in the images folder of your Dreamweaver website.


3. Select Edit > Insert > New Button.


A new button is added to the Document Library. The button editor opens and the Property inspector displays 
button properties (Figure 1).


Figure 1 Button Property inspector


4. Deselect the Enable option for 9-Slice Scaling Guides in the Property inspector. (To learn about 9-Slice Scaling 
Guides, select Help > Fireworks Help).


Buttons contain four states:


• Up (button untouched)


• Over (pointer over button)


• Down (button being clicked)


• Over While Down (pointer over while button held down)


You can view each state by selecting it in the State pop-up menu in the Property inspector (Figure 1). The current 
state of the new button is Up, as shown in the Property inspector.


5. Use the Rectangle tool or the Ellipse tool from the Tools panel to draw a shape for the Up state. Make the 
dimensions of the shape fit the size of your navigation bar.


6. To add depth to the button, click the Add Live Filters button in the Property inspector (the plus sign next to 
Filters), and then select a bevel option from the pop-up menu:


• Bevel and Emboss > Inner Bevel


• Bevel and Emboss > Outer Bevel


State pop-up menu 9-slice scaling guides Enable/Disable option
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7. Using the Property inspector, add color to the button. Using the Text tool, add text to the button. 


These should match the color and font design of your page.


8. Switch to the Pointer tool. Hold down Shift. Click on both the button and the text box to select both.


9. Select Modify > Align > Center Vertical to align the text with the vertical center of the button.


10. Select Modify > Align > Center Horizontal to align the text with the horizontal center of the button.


Later you will duplicate this first button to create the other buttons. If the text is centered, button labels with 
varying numbers of characters will all be well aligned.


11. Click away from the shape and text to deselect them. In the Property inspector, select Over in the State pop-up 
menu (Figure 2).


Figure 2 State pop-up menu


12. In the Property inspector, click Copy Up Graphic to copy the Up graphic to the Over button state (Figure 3). 


This saves you time and helps keep the look and position of the button consistent.


Figure 3 Copy Up Graphic button


13. Decide how you want the button to look when the pointer rolls over the button. Then change the copied graphic 
by modifying the color or effects of the text or the shape of the button.


14. Click away from the shape and text to deselect them. In the Property inspector, select Down in the State pop-up 
menu.


15. Click Copy Over Graphic to copy the Over graphic to this button state.


16. Decide how you want the button to look when visitors click the button. Add effects such as darkening the color. 


You can add a drop shadow to the shape by clicking Add Filters in the Property inspector, and then selecting 
Shadow And Glow > Drop Shadow.


Note: For this project, you will skip the Over While Down state.


17. Click away from the shape and text to deselect them. In the Property inspector, select Active Area in the State 
pop-up menu.


State pop-up menu


Copy Up Graphic button
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The active area of the button is shown by green shading and red lines. This shading indicates the area visitors can 
click to activate the button.


18. To change the size of the active area, drag the red guides to extend or decrease the green shaded active area.


19. When you are satisfied with the states of your button in the Button Editor, click Page 1 at the top of the screen 
(Figure 4) to close the Button Editor and return to the Page 1 canvas.


Your button appears on the Fireworks Page 1 canvas. 


Figure 4 Close the Button Editor and return to the Page 1 canvas


20. Click the button to select it. In the Link text box in the Property inspector, enter the name of a web page to link to 
this button (Figure 5).


Figure 5 Web page in Link text box


21. In the Alt text box, enter an alternative text label for the button.


Alternative text is displayed in place of the image when visitors elect not to display images in their browsers. 
Such text can also be voiced by screen readers for visitors who use them. Typically, alternative text for a button 
should be the same as the text displayed on the button.


22. Select Modify > Canvas > Fit Canvas to fit the canvas to the size of your button.
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Copying buttons and making the navigation bar


In the following steps, you duplicate the button you created in the previous steps to make the navigation bar.


To copy the buttons and make the navigation bar:


1. Change the size of the canvas to accommodate all the 
buttons on your navigation bar. Select Modify > Canvas 
> Canvas Size and edit the value for height or width in 
the Canvas Size dialog box.


If you have four buttons, for example, multiply the height 
or width of the first button by four (depending on 
whether your navigation bar is vertical or horizontal).


2. Select the first button. Move it to the top of the canvas. 
Select Edit > Clone.


A new instance of the button appears on top of the 
original button.


3. Drag the new button instance below the original button. 
You can also use the arrow keys to move the button.


4. Repeat steps 2 and 3 as many times as necessary to create 
the rest of your navigation bar (Figure 6).


5. Click the second button and use the Property inspector to 
edit it. In the Text box, change the text to the name of the 
second button. Edit the information in the Link text box 
and the Alt text box as appropriate for this button.


6. Repeat step 5 for the remaining buttons (Figure 7).


7. Fit the canvas to your navigation bar: Select Modify > 
Canvas > Fit Canvas.


8. Save the file.


Figure 6 Cloned buttons


Figure 7 Buttons with edited text labels
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Exporting a navigation bar for use in Dreamweaver


Fireworks enables you to save interactive graphics (a button, for instance) as HTML so you can import working 
buttons into a Dreamweaver document.


To export a navigation bar for use in Dreamweaver:


1. Choose File > Export.


The Export dialog box opens (Figure 8).


2. Navigate to the folder in your local root folder where you 
want to save the navigation bar.


3. Give the navigation bar file a short descriptive name.


4. Make sure the Selected Slices Only option is not selected.


5. Make sure HTMLAnd Images is selected in the Export 
pop-up menu.


6. Make sure the Include Areas Without Slices option is 
selected.


7. Select the Put Images In Subfolder option.


8. Click Save (Windows) or Export (Mac OS).


9. Save the Fireworks document, and close Fireworks.
Figure 8 Export dialog box


Export pop-up menu
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Inserting the navigation bar into a Dreamweaver document


Now that you’ve created the navigation bar, you can insert it into a Dreamweaver document. You do so by using an 
option in the Insert panel.


To insert the navigation bar into a Dreamweaver document:


1. Start Dreamweaver.


2. Open the page in which you want to insert the navigation 
bar. Save the Dreamweaver document before importing.


3. Position the insertion point where you want the 
navigation bar to appear.


4. In the Common category on the Insert panel, click the 
Images pop-up menu and select Fireworks HTML.


The Insert Fireworks HTML dialog box opens 
(Figure 9).


5. In the Insert Fireworks HTML dialog box, click the 
Browse button, and then locate and select your 
navigation bar HTML file. Click Open.


6. In the Insert Fireworks HTML dialog box, click OK.


The navigation bar appears on the page.


7. To edit a button, select the button and then use the 
Property inspector to change settings such as the link or 
alternative text.


8. Check that the link address and the alternative text label 
are correct for each button.


9. Select File > Preview In Browser and choose a browser 
from the submenu to test the buttons and their links in a 
browser (Figure 10).


10. Save the Dreamweaver document.


Figure 9 Fireworks HTML dialog box


Figure 10 Page previewed in browser
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How to create links
There are several different types of links in Adobe Dreamweaver CS5:


• An internal link (document-relative pathname link or site-root-relative pathname link) goes to another page in 
your site. 


• An external link (absolute pathname link) goes to another site. 


• A named anchor link goes to a specific position on a page in your site.


• An e-mail link opens a blank e-mail message window instead of linking to a page.


Creating an internal link 


Internal links do not need their full URL, and you can create these by browsing to or pointing to their target files 
through the Text Property inspector.


To add an internal link:


1. Save your Dreamweaver document. 


Note: In order for internal links to be set up properly, you 
should save your document  in the designated location for 
your site on your computer. See the guide “How to set up 
a local root folder and site structure” for more details.


2. Select an image, a word, or a phrase of text you want to 
format as a link. (When users click on the word, phrase, 
or image, the link will open.)


Make sure the Property inspector is open (Figure 1). It is 
docked at the bottom of the screen. If the Property 
inspector is not open, select Window > Properties.


3. Click HTML in the Property inspector (Figure 1).


4. Beside the Link text box (Figure 1), click the Browse For 
File (file folder) icon.


The Select File dialog box opens (Figure 2).


5. Browse to the file you want to link and click on it.


6. Click OK.


The Select File dialog box closes. The filename appears 
in the Link text box in the Property inspector.


Note: To the left of the Browse For File icon is the Point 
To File icon. If you have the Files panel open, you can 
click and drag the Point To File icon to draw a link line to 
the target file in the Files panel. The name of the file you 
point to will be added to the Link text box automatically.


Figure 1 Text Property inspector


Figure 2 Select File dialog box


HTML Point to File Browse for File
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Creating an external link


External links need their full address to work. You need to enter these by hand or copy them from a browser address 
bar and paste them into the Link text box in the Text Property inspector 


To add  a link to a page on another site:


1. Select an image or text you want to format as a link.


2. In the Link text box in the Property inspector, type or 
paste the address (URL) of the site to which you want to 
link (Figure 3).


Remember to include “http://” in the address.


Note: If you want the link to open in a new browser 
window, select the link and use the Target pop-up menu 
in the Property inspector to select “_blank.”


Figure 3 Creating an external link


Creating a link to a named anchor


To link to a specific location on a web page, first create a named anchor at that location, and then link to the named 
anchor. 


To create and link to a named anchor:


1. Position the insertion point at the location on the page 
where you want to define an anchor.


2. Select Insert > Named Anchor. 


The Named Anchor dialog box opens (Figure 4).


3. Enter a short anchor name without any spaces.


4. Click OK.


5. Select an image or text to link to the named anchor.


6. In the Link text box in the Property inspector, type “#” 
and then type or paste the anchor name.


Figure 4 Named Anchor dialog box


Link text box Target pop-up menu







Adobe Dreamweaver CS5 Activity 2.8 guide


© 2010 Adobe Systems Incorporated How to create links 3


Creating a link to an e-mail address


You can add a link to an e-mail address. When visitors click the link, their default mail applications will start.


To create a link to an e-mail address:


1. Click in the document where you want the link to appear, 
or select the text or image you want to format as the e-
mail link.


2. Do one of the following to insert the link:


• Select Insert > Email Link.


• In the Common category of the Insert bar, click the 
Email Link button.


The Email Link dialog box opens (Figure 5).


3. In the Text box, enter text for the link.


If you selected text to format as the link, that text appears 
in the Text box.


4. In the Email text box, type the e-mail address.


5. Click OK to close the Email Link dialog box.


Figure 5 Email Link dialog box
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How to create lists
You can create numbered lists and bulleted lists from existing text or from new text as you type in the Document 
window. Numbered lists are also called ordered lists. Bulleted lists are also called unordered lists.


Creating numbered lists


In Adobe Dreamweaver CS5, you can use numbered lists (Figure 1) to organize information that needs to be in order. 
You can apply numbering as you create the list, or you can add numbering to an existing list.


To create a numbered list:


1. Place the insertion point in your document where you 
want to add the list.


2. In the Property inspector, click HTML, and then click the 
Ordered List button (Figure 2).


3. Type the first list item.


4. Press Enter (Windows) or Return (Mac OS) at the end of 
each list item to type another item.


5. When you finish typing the list, press Enter (Windows) or 
Return (Mac OS) twice to turn off the list function.


Figure 1 A numbered list


Figure 2 List buttons in the Property inspector


Unordered listHTML option Ordered list
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Creating bulleted lists


Use bulleted lists (Figure 3) to organize information that does not need to be in order. You can apply bullets as you 
create the list, or you can add bullets to an existing list.


To create a bulleted list:


1. Place the insertion point in your document where you 
want to add the list.


2. In the Property inspector, click HTML, and then click the 
Unordered List button (Figure 2).


3. Type the first list item.


4. Press Enter (Windows) or Return (Mac OS) at the end of 
each list item to type another item.


5. When you finish typing the list, press Enter (Windows) or 
Return (Mac OS) twice to turn off the list function.


Figure 3 A bulleted list


To create a bulleted list from existing text:


1. Select multiple lines of existing text.


2. Click the Unordered List button in the Property inspector 
(Figure 2).
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How to create data tables
In Adobe Dreamweaver CS5, you can use tables to create and format data. Although it is possible to use tables for 
page layout, including text and images, tables are primarily used to display information in simple columns and rows. 
After you create a table, you can easily modify both its appearance and its structure.


You can insert a new table from the Insert panel, or you can import a spreadsheet table created in a program such as 
Microsoft Excel. 


Inserting a table on a page


You can insert a table anywhere on a page, including within another table. You can quickly insert a standard table 
with three rows and three columns, or you can modify options to insert a custom table.


When you insert a table, a good idea is to set a header property for a row or column if you will use that row or column 
to provide labels for the information in the table. A header makes the table more accessible to people with visual 
impairments, because screen readers can recognize that a header contains labels. (Note that you must set a header row 
or column to provide such accessibility. It is not sufficient to use bold or centered text.)


To insert a table:


1. Open a document in Dreamweaver.


2. Place the insertion point in your document where you 
want the table to appear.


3. Select the Common category in the Insert panel, and 
make sure Standard mode is selected.


4. Click the Table button on the Insert panel (Figure 1).


The Table dialog box opens (Figure 2).


5. Enter the number of rows and columns.


6. Make changes to any of the options in the dialog box. For 
information about the options, click the Help button in 
the dialog box.


Applying a column header or row header in particular 
can improve the accessibility of a data table. The browser 
will display these headers slightly differently, and such 
headers are read by screen readers.


Figure 1 Common category in the Insert panel


Figure 2 Table dialog box
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To set a header row or column:


1. In the Table dialog box (Figure 2), select one of the 
options in the Header section.


For example, if you create a table that lists a collection of 
books, with columns labeled Author, Title, and Year, you 
should set the top row as a header. By default, header 
rows or columns are bolded and centered (Figure 3). 
Screen readers can now read this header.


2. Click OK.


The table appears in your document.


Figure 3 Table with top row set as header


Selecting table elements


You can select an entire table, a row, or a column, or you can select a contiguous block of cells within a table. After 
you’ve selected a table or cells, you can modify the appearance of the selection or of the text contained in the 
selection.


To select an entire table:


Do one of the following:


• Click the upper-left corner of the table or click 
anywhere on the bottom edge.


• Click in a table cell, and then select Modify > Table 
> Select Table.


Selection handles appear on the selected table’s lower 
and right edges (Figure 4).


Figure 4 Selection handles on a selected table


To select rows or columns:


1. Position the pointer to point at the left edge of a row or 
the top edge of a column.


2. When the pointer changes to a selection arrow, click to 
select the row or column, or drag to select multiple rows 
or columns (Figure 5).


Figure 5 A selected column in a table


To select a single cell:


Do one of the following:


• Click in the cell. Then drag to select the cell.


• Click in the cell. Then select Edit > Select All.
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Adding rows and columns


You can add a single row or column, or you can add multiple rows or columns at the same time.


To add a row:


1. Place the insertion point in a table cell, or select an entire 
row.


2. Do one of the following:


• In the Layout category in the Insert panel, click the 
Insert Row Above button or the Insert Row Below 
button (Figure 6).


• Select Insert > Table Objects > Insert Row Above or 
Insert > Table Objects > Insert Row Below.


A new row appears above or below the insertion point or 
the selected row.


Figure 6 Layout category in the Insert panel


To add a column:


1. Place the insertion point in a table cell, or select an entire 
column.


2. Do one of the following:


• In the Layout category in the Insert panel, click the 
Insert Column To The Left button or the Insert 
Column To The Right button (Figure 6).


• Select Insert > Table Objects > Insert Column To 
The Left or select Insert > Table Objects > Insert 
Column To The Right.


A new row appears to the left or right of the insertion 
point or the selected column.







Activity 2.7 guide Adobe Dreamweaver CS5


4 How to create data tables © 2010 Adobe Systems Incorporated


Deleting rows and columns


You can delete a single row or column, or you can delete multiple rows or columns at the same time.


To delete rows or columns from a table:


1. Select one or more rows or columns.


2. Press Delete or Backspace.


To remove cell contents, but leave the cells intact:


1. Select one or more cells.


2. Select Edit > Clear or press Delete.


Note: If you select an entire row or column, and then 
select Edit > Clear or press Delete, Dreamweaver 
removes the entire row or column—not just their 
contents—from the table.


Resizing tables, rows, and columns


You can resize an entire table or individual rows and columns. When you resize an entire table, all the cells in the 
table resize proportionately.


To resize a table:


Select the table and do one of the following.


• To resize the table horizontally, drag the selection 
handle on the right.


• To resize the table vertically, drag the selection 
handle on the bottom.


• To resize in both dimensions, drag the selection 
handle at the lower-right corner.


To resize a column’s width:


Do one of the following: 


• Drag the right border of the column. 


• Select the column. In the Property inspector 
(Figure 7), change the number in the Column Width 
text box.


Figure 7 Table Property inspector


Column Width Row Height
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To resize a row’s height:


Do one of the following: 


• Drag the lower border of the row. 


• Select the row. In the Property inspector (Figure 7), 
change the number in the Row Height text box.


Modifying table properties


You can modify the properties of a table, its rows and columns, or its cells by using the Property inspector. Attention 
to table borders and cell padding (the amount of spacing between table cells) in particular can help you create 
effective table designs.


You can also set a row or column as a header by using the Property inspector. Headers help make tables more useful 
and accessible.


To modify table properties:


1. Select the table you want to modify.


2. Make changes to any of the options in the Property 
inspector (Figure 8).


Figure 8 Table Property inspector


To modify table row or column properties:


1. Select the row or column you want to modify.


2. Make changes to any of the options in the Property 
inspector.


To modify table cell properties:


1. In your document, select the cell or cells you want to 
modify.


2. Make changes to any of the options in the Property 
inspector (Figure 9). Figure 9 Table cell Property inspector 


To set a row or a column as header:


1. Select a row or column.


2. In the Property inspector, select the Header option.


The words in the row or column will appear centered and 
bolded (Figure 10).


Figure 10 Table with top row set as header
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Inserting a spreadsheet table


To insert a spreadsheet created in another application, such as Microsoft Excel, save the spreadsheet file in tab-
delimited (txt) or comma-separated-values format (csv). These tables are a quick way for setting up the layout for a 
catalog or directory of information.


To save a spreadsheet in TXT or CSV format:


1. Open a spreadsheet file in the program in which you 
created it, such as Microsoft Excel.


2. Select File > Save As.


3. For the file format, select either Text (Tab Delimited) or 
CSV (Comma Delimited) in the Save As Type 
(Windows) or Format (Mac OS) pop-up menu to save the 
spreadsheet as a data file.


4. Save and close the spreadsheet program.


To insert the spreadsheet into a Dreamweaver document:


1. Start Dreamweaver and open the document into which 
you want to insert the spreadsheet table.


2. Select the Data category in the Insert panel and click the 
Import Tabular Data button (Figure 11).


The Import Tabular Data dialog box opens (Figure 12)).


3. In the dialog box, click Browse and select the spreadsheet 
file. Click Open.


4. On the Delimiter pop-up menu (Figure 13), select Tab if 
you saved the spreadsheet file in tab-delimited format or 
select Comma if you saved the file in CSV format.


5. Click OK to close the Insert Tabular Data dialog box.


The contents of the spreadsheet file are displayed in a 
table on the page.


Figure 11 Import Tabular Data button on Insert 
panel


Figure 12 Import Tabular Data dialog box


Figure 13 Delimiter pop-up menu
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To sort table data: 


1. Select the table and select Commands > Sort Table.


The Sort Table dialog box opens (Figure 14). You can 
select which column to sort by and sort alphabetically or 
numerically. You can sort first by one column, and then 
sort the data further by a second column.


2. Select your sort preferences, and click OK.


Figure 14 Sort Table dialog box
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How to set document properties
You can use the Page Properties dialog box to set page layout and formatting properties, such as a default font family, 
font size, font color, and background color.


Seting document properties


To open the Page Properties dialog box:


1. Open a document in Adobe Dreamweaver CS5.


2. Select Modify > Page Properties.


The Page Properties dialog box opens (Figure 1).


Figure 1 Page Properties dialog box


To change the default font for a page:


1. Select a font in the Page Font pop-up menu.


2. Select a font size in the Size pop-up menu.


Any unformatted text will appear in the selected font and 
font size.


To change the default text color for a page:


1. Click the Text Color box.


2. Select a color in the color picker (Figure 2).


Figure 2 Text color picker
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To change the background color of a page:


1. Click the Background Color box.


2. Select a color in the color picker (Figure 3).


3. Click OK.


Figure 3 Background color picker
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How to plan a portfolio
Planning a website by using information architecture is a common practice for professional designers. Designers 
create a flowchart that shows all the pages in the site and how they connect. The flowchart can also describe the 
purpose and audience for a site and provide organized lists of content.


Create a flowchart for your portfolio that shows the organization and content of your work in this course. Include the 
following:


1. Describe the purpose of the portfolio.


2. Include a list of assets in the portfolio, and organize files and projects into categories.


3. Using your category outline from step 2 as a guide, draw a flowchart for your web portfolio.
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How to publish web files
After you finish editing your documents, you need to publish them to your web server so the documents can be 
viewed.


Connecting to a remote site


Many websites let you publish files through FTP (File Transfer Protocol). You connect to a remote site by using the 
Site Definition dialog box in Adobe Dreamweaver CS5.


To connect to a remote site:


1. Select Site > Manage Sites from the menu bar.


The Manage Sites dialog box opens (Figure 1).


2. Select the name of the site you want to connect remotely, 
and click Edit.


The Site Setup dialog box opens.


3. Click Servers in the left column  (Figure 2).


The Servers area of the Site Setup dialog box opens.


4. Click the Add Server button (+).


5. Enter the FTP access information as directed by your 
teacher.


6. Click Test to test the connection.


Dreamweaver confirms the connection.


7. Click Save.


The new server appears in the list of servers in the Site 
Setup dialog box.


8. Click Save to close the Site Setup dialog box.


9. Click Done to close the Manage Sites dialog box.


Figure 1 Manage Sites dialog box


Figure 2 Servers area of the Site Setup dialog box
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Uploading and downloading files


Once you establish an FTP connection, you can publish files directly from the Files panel.


To upload the entire site for the first time:


1. Make sure the Files panel is open (Figure 3).


The Files panel is typically located on the right side of 
the screen. If the Files panel is not open, select Window > 
Files.


2. Click the Expand/Collapse button in the Files panel 
toolbar (Figure 3).


The Files panel expands (Figure 4).


3. Make sure the Connects To Remote Host button is active 
(Figure 5). Click it if necessary.


Dreamweaver connects to the web server.


4. Select the root folder for your site in the Local (right) 
pane.


5. Click the Put Files button (the upward-pointing arrow).


Dreamweaver uploads the site’s files and opens the 
Background File Activity dialog box (Figure 6).


Note: To upload one or more folders or files without 
uploading the entire site, select them and click the Put 
Files button.


Figure 3 Files panel


Figure 4 Expanded Files panel


Figure 5 Files panel toolbar


Figure 6 Background File Activity dialog box
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To upload a revised version of an existing file:


1. Select the file you have revised.


2. Click the Put Files button.


Dreamweaver uploads the revised file.


Downloading files to work on them


Once your website has been published, you will often want to download a file so you can revise it. You do so through 
the Remote Site pane, on the left side of the expanded Files panel.


To download a file:


1. Click the Refresh button (Figure 7) to make sure the files 
in the Remote Site pane are up-to-date.


2. Select a file to download.


3. Click the Get Files button (Figure 7).


If the file has any dependent files, the Dependent Files 
dialog box opens (Figure 8). Dependent files are files, 
such as images or Flash movies, incorporated into a web 
page. In most cases, you need to download these in order 
for a web page to appear correctly. 


Note: If you do not click Yes within 30 seconds, the 
Dependent Files dialog box automatically closes and 
dependent files are not downloaded.


4. Click Yes.


Dreamweaver copies the file and its dependent files to 
your local folder. The downloaded files appear in the 
right pane of the expanded Files panel.


5. Click the Disconnects From Remote Host button 
(Figure 7), and then collapse the Files panel.


Figure 7 Files panel toolbar


Figure 8 Dependent Files dialog box
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How to set up a local root folder and site structure
The first thing to do when creating a new website with Adobe Dreamweaver CS5 is to define a site and identify a root 
folder where you will save all files, images, and other elements for the web pages.


Setting up a local root folder


A local root folder is a folder on your computer. You first need to create the folder before you can select it for your 
site.


To set up a local root folder:


1. Create a folder on your computer to serve as the main 
folder for your website. Give the folder a name that 
identifies the website. 


This folder is called the local root folder.


Note: When creating a root folder for a site on your 
computer, it is highly recommended that you place it at 
the top level of your hard drive. For example, C:\my site 
(Windows) or Macintosh HD: my site (Mac OS).


2. Start Dreamweaver.


3. From the menu bar, select Site > Manage Sites.


The Manage Sites dialog box opens.


4. Click New.


The Site Setup dialog box opens (Figure 1). 


5. Delete the temporary name, Unnamed Site 1. Enter a new 
name for the site. 


6. Click the Folder icon to the right of Local Site Folder.


The Choose Root Folder dialog box opens (Figure 2).


7. Locate and select the root folder you created for your site. 
Click Open and then Select (Windows), or click Choose 
(Mac OS).


8. Click Save.


Your local root folder is defined.


9. Click Done in the Manage Sites dialog box.


On the right side of the Dreamweaver window, the Files 
panel displays the folders and files of your site 
(Figure 3). In Windows, the Files panel is one of the 
docked panels at the right side of the window. You can 
leave this panel open as you work. If the panel is not 
docked, you may want to close it.


Figure 1 Site Setup dialog box (Basic)


Figure 2 Choose Root Folder dialog box


Figure 3 Files panel
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Modifying site information


You can change settings for your site at any time.


To modify site information:


1. Select Site > Manage Sites from the menu bar.


The Manage Sites dialog box opens (Figure 4).


2. Select the site name and click Edit.


The Site Setup dialog box opens.


3. Change any of your original settings as desired.


Figure 4 Manage Sites dialog box
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How to lay out a web page with CSS
You can use table design features in Adobe Dreamweaver CS5 to create a simple page layout. However, a more 
powerful technique is to use Cascading Style Sheets (CSS). The basic building block of CSS layout is the div tag—an 
HTML tag that in most cases acts as a rectangular container for text, images, and other page elements. When you 
create a CSS layout, you place div tags (or divs) on the page, add content to them, and position them in various 
places. Unlike table cells, which are restricted to existing somewhere within the rows and columns of a table, divs can 
appear anywhere on a web page. You can position divs absolutely (by specifying x- and y-coordinates), or relatively 
(by specifying their distance from other page elements).


In Dreamweaver, you can quickly and easily place an AP div (short for absolutely positioned div tags). These 
elements provide great control over the page layout, reduce the amount of code you need, and enable you to format 
layout blocks with margins, borders, and colors. In addition, people using screen readers to view web pages have a 
much easier time browsing pages built with CSS because the code is simpler and shorter. The limitation of an AP div, 
however, is that since it is absolutely positioned, its position never adjusts on the page to accommodate to the size of 
the browser window.


You will learn more about CSS in later units.
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Creating a new page


In the following steps, you will create a new HTML page to which you will later add divs.


To create a new page:


1. Start Dreamweaver.


2. Make sure the Files panel is visible (Figure 1). 


It is docked at the right side of the screen. If the Files 
panel is not open, select Window > Files.


3. Make sure your portfolio site is selected. If it is not, click 
the Site pop-up menu and select your portfolio site.


4. Select File > New.


The New Document dialog box opens (Figure 2).


5. With the Blank Page category selected, click HTML 
under Page Type and <none> under Layout.


6. Click Create.


A new untitled HTML document opens.


7. To save the untitled document as your home page, select 
File > Save As.


The Save As dialog box opens to the root folder of your 
portfolio site.


8. Name the new page index.html and click Save.


The new file, index.html, is added to the root folder in the 
Files panel (Figure 3).


Figure 1 Files panel


Figure 2 New Document dialog box


Figure 3 To save the untitled document as your 
home page, select File > Save As.
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Inserting a div tag


To insert a div tag:


1. Select the Layout category in the Insert panel.


Make sure the Standard mode button is selected 
(Figure 4).


2. Click the Draw AP Div button (Figure 4).


The mouse pointer chnages to a cross when you move it 
over the page.


3. Select one of the page areas on your storyboard. To create 
the div that will define this area on your page, drag a 
rectangle in the Dreamweaver document. When the 
rectangle matches the page area’s size on your 
storyboard, release the mouse button. 


4. Click the border of the div to select it.


Handles appear along the border (Figure 5) and the div 
properties appear in the Property inspector. 


5. Make sure the Property inspector is open (Figure 6). 


It is docked at the bottom of the screen. If the Property 
inspector is not open, select Window > Properties.


6. Click in the CCS-P Element ID box (Figure 6) and enter 
a name for the div. 


Choose a unique name that will help you remember the 
div’s contents, such as header or navigation.


Note: “CSS-P” is a commonly accepted abbreviation for 
“CSS Positioning”.


7. Click the Bg Color box and select a color in the color 
picker. 


The div changes to the selected color.


8. Open the AP Elements panel (Window > AP Elements).


You’ll see that Dreamweaver has added the new div to 
the list of AP Elements. 


9. Click once outside the new div to deselect it. 


A thin black line appears around the div. This line does 
not appear in a browser. If you do not see the line, select 
View > Visual Aids > CSS Layout Outlines.


10. Continue adding divs for all the sections on your 
storyboard. You can place divs directly alongside one 
another (Figure 7).


11. Save your page.


Figure 4 Insert panel, Layout category


Figure 5 Div inserted and selected


Figure 6 Property inspector


Figure 7 Multiple divs on page


Draw AP Div button


CSS-P Element ID box


AP 
Elements 
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Resizing divs


You can resize an individual div or simultaneously resize multiple divs to make them the same width and height.


Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to resize a div so it 
overlaps with another div.


To resize a div:


1. Select a div by clicking its border or by clicking the div’s 
name in the AP Elements panel.


2. Do one of the following to resize the div:


• To resize by dragging, drag any of the div’s resize 
handles (Figure 8).


• To resize one pixel at a time, hold down Control 
(Windows) or Option (Mac OS) while pressing an 
arrow key.


Note: The arrow keys move the right and bottom 
borders of the div; you can’t resize the top and left 
borders with this technique.


• In the Property inspector, type values for width (W) 
and height (H).


Figure 8 Resize by dragging


Moving divs


You can move divs in Design view in much the same way you move objects in most basic graphics applications.


Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to move a div so that 
it overlaps another div.


To move a div:


1. Select one or more divs.


2. Do one of the following:


• To move by dragging, drag the div’s selection handle 
(Figure 9).


• To move one pixel at a time, use the arrow keys.


Figure 9 Moving a div


Div resize handle


Selection handle
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Adding content to divs


You can add images, text, and other content (such as Flash movies) to your divs just as you would elsewhere in a web 
page.


To add content to a div:


1. To insert an image in a div, click in the div and select 
Insert > Image on the menu bar.


Note: Make sure the div is sized large enough to hold the 
image or other content. If the div is sized smaller than the 
image, the div may not display correctly in all browsers.


2. In the Select Image Source dialog box, locate and select 
an image to insert (such as your page banner). Then click 
OK (Windows) or Choose (Mac OS).


The image appears on the div (Figure 10).


3. To format the image in the div, select the image and 
select formatting elements in the Property inspector.


4. To add text to a div, click in the div and type text or paste 
text copied from another document.


Figure 10 Div with image added
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Viewing div tags by using Live view


You can use a feature called Inspect mode in Live view to view the code generated by adding the div tags.  


To view div tags using by using Inspect mode in Live view:


1. Click the Inspect button (Figure 11).


A message appears below the Inspect button asking if 
you want to switch workspace settings. 


2. Click Yes (Windows) or Switch Now (Mac OS).


When you do, the following settings are applied: 


• CSS styles panel is open to Current mode. When you 
move the mouse pointer over a page element created 
with CSS, details about the rule appear in the CSS 
styles panel.


• Split Code/Live view is enabled. This lets you see 
the code alongside the design display. Live view 
displays the page as it will appear in a web browser, 
without your needing to launch a browser.


• Live Code is enabled. This means that the page 
appears as it will in a web browser.


3. Move the mouse pointer over a div in the right pane. 
Observe that the div tag is highlighted in the left pane 
(Figure 12).


Figure 11 Inspect button


Figure 12 Inspect mode


Previewing divs in a browser


To preview the page in a browser:


• Select File > Preview In Browser and then select a 
browser from the submenu (or press F12).


The page opens in the selected browser (Figure 13).


Note: It is important to preview in a browser to make 
sure your design fits in a standard browser window. Try 
resizing the browser window to see the effect on your 
page.


Figure 13 Web page in a browser window


Inspect button


DivHighlighted tag
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HTML tags
The following is a quick reference guide for common tags used in HTML pages.


Main setup tags for an HTML document


<html>


<head>


<title>


</title>


</head>


<body>


</body>


</html>


<html></html>  encompasses all tags in an HTML document and defines it as an HTML document.


<head></head> encompasses the title tag and contains document titles and authoring information for the 
document.


<title></title> encompasses the title for the document.


<body></body>  encompasses all the tags that make up the document.


Main formatting tags for the document


<h1></h1> is a heading tag that creates the largest size text. The heading tag number can range from 1 to 6. 
Increasing the number makes the text smaller.


<p></p> creates a paragraph.


<br> creates a line break.


<strong></strong> bolds text.


<em></em> emphasizes text with italics.


Links


<a href="http://www.example.com"></a> inserts a link to the address provided in the href attribute.


Data tables


<table></table> creates a table. This pair of tags encompasses all the row and cell tags in the table.


<tr></tr> creates the rows of a table. This pair of tags encompasses all the cell tags in a table row and must be 
placed inside <table></table> tags.


<td></td> creates a cell in a table row and must be placed inside <tr></tr> tags.


<th></th> creates a table header cell in a table row. Like <td></td> tags, these must be placed inside <tr></tr> 
tags.
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Lists


<ol></ol> creates an ordered list. 


<ul></ul> creates an unordered list. 


<li></li> encompasses a list item and must be placed inside either <ol></ol> tags or <ul></ul> tags.
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The Dreamweaver Insert panel
In Adobe Dreamweaver CS5, the Insert panel contains buttons for inserting various types of objects, such as images 
and forms, into a web page.


You can use the Insert panel to create or insert content in eight categories:


• The Common category contains buttons for inserting the most commonly used objects, such as links, images, and 
tables.


• The Layout category gives you options to insert tables, div tags, layers, and frames. You can view tables in either 
Standard (default) mode or Expanded Tables mode. 


• The Forms category contains buttons for creating forms and inserting form elements.


• The Data category lets you insert dynamic elements such as recordsets, repeated regions, and record insertion 
and update forms.


• The Spry category lets you insert “widgets” that display data from other files and various interface elements 
(such as navigation bars and menus) that rely on JavaScript and CSS. (Spry widgets are not covered in this study, 
but you can read find out more about them in Dreamweaver Help (select Help > Dreamweaver Help and look for 
the section called “Building Spry pages visually.”)


• The InContext Editing category is used to enable end users to make simple edits to their web pages without help 
from you or additional software on their computers. Adobe InContext Editing (ICE) is an online hosted service 
that provides simple content editing capabilities within a web browser. 


• The Text category is used for working in Code view and enables you to insert a variety of text- and list-formatting 
tags, such as b, em, p, h1, and ul.


• Use the Favorites category to customize a list of Insert panel buttons for fast access. You can customize this 
category by right-clicking (Windows) or Control-clicking (Mac OS) the Insert panel.


The Insert panel menu


You switch between these categories by using the Insert panel menu, which is located at the top of the Insert panel 
(Figure 1).


Figure 1 Insert panel menu
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The Dreamweaver Insert panel


Student name:_________________________________________________ Date: ________________________


In Adobe Dreamweaver CS5, the Insert panel contains buttons for inserting various types of objects, such as images 
and forms, into a document (web page). The Insert panel contains several categories, such as Common and Layout.


Identify and describe the buttons on the Common category in the Insert panel.
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Identify and describe the buttons on the Layout category in the Insert panel.
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Describe the contents of the other categories of the Insert panel.


Forms category: ________________________________________________________________________________


Data category: _________________________________________________________________________________


Spry category: _________________________________________________________________________________


InContext Editing category: _______________________________________________________________________


Text category:__________________________________________________________________________________


Favorites category:______________________________________________________________________________


On the Insert panel below, indicate where you can switch back and forth between categories:





		The Dreamweaver Insert panel
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Managing files and links by using the Files panel
You can organize and manage your site files and folders by using the Files panel in Adobe Dreamweaver CS5. Use 
the Files panel to open, add, rename, or delete files and folders. Use the Files panel to modify links.


Opening files


The Files panel provides a handy way to open a site’s files.


To open a file:


1. Make sure the Files panel is visible (Figure 1).


The Files panel is typically located on the right side of 
the screen. If the Files panel is not open, select Window > 
Files.


2. Select a file in the Files panel.


3. Do one of the following:


• Double-click the files's icon.


• Right-click (Windows) or Control-click (Mac OS) 
the file's icon, then select Open.


Note: If Check In/Check Out is enabled, Dreamweaver 
will check the file out before it opens the file. If another 
visitor has checked out the file, Dreamweaver will warn 
you about the file’s status and let you know who has it 
checked out. You can then decide whether to continue 
opening the file or not.


Figure 1 Files panel
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Renaming files


When you rename a file in the Files panel, Dreamweaver can automatically change links that point to this file. For 
this reason, it is always preferable to rename site files by using the Files panel instead of renaming them on your hard 
disk.


To rename a file:


1. Do one of the following to select the name of a file or 
folder in the Files panel:


• Click the name, pause, and then click again.


• Right-click (Windows) or Control-click (Mac OS) 
the file or folder icon, and then select Edit > 
Rename.


1. Type the new name.


2. Press Enter (Windows) or Return (Mac OS).


If any site links point to the file or folder, the Update 
Files dialog box opens (Figure 2).


3. Click Update to change links that point to the renamed 
file or to a file in the renamed folder.


Figure 2 Update Files dialog box


Deleting files


When you delete a file or folder, Dreamweaver will warn you if links in other documents point to the file or folder. 


To delete a file:


1. Click the file or folder in the Files panel you want to 
delete.


1. Press Delete.


If any site links point to the file or folder, the Delete Files 
warning opens (Figure 3), giving you the opportunity to 
change the links before you delete the file.


To delete the file anyway, click Yes. To cancel your 
request to delete the file, click No.


Figure 3 Delete files warning







Adobe Dreamweaver CS5 Activity 2.13 guide


© 2010 Adobe Systems Incorporated Managing files and links by using the Files panel 3


Changing links to a file


You can also change links to a file through the Files panel. It is a good idea to change links before you delete a file to 
which other files are linked.


To change links to a file:


1. Select a file in the Files panel.


1. Select Site > Change Link Sitewide.


The Change Link Sitewide dialog box opens (Figure 4).


2. In the Into Links To text box, enter the name of the file to 
which new links should point.


3. Click OK.


The Update Files dialog box opens (Figure 5).


4. Click Update.


Figure 4 Change Link Sitewide dialog box


Figure 5 Update Files dialog box







Activity 2.13 guide Adobe Dreamweaver CS5


4 Managing files and links by using the Files panel © 2010 Adobe Systems Incorporated


Creating a new folder


Use folders to keep your site well organized. For example, most websites use a folder named images to store all the 
images for the site.


To create a new folder:


1. Right-click (Windows) or Control-click (Mac OS) the 
site root folder (or the existing folder in which you want 
to create the new folder).


Note: While small sites may have only one level of 
folders, more complex sites may have multiple levels.


A context menu appears.


2. Select New Folder.


The new folder appears as a subfolder of the root folder. 
The name of the folder should be highlighted (Figure 6).


3. Type a name for the folder.


4. Press Enter (Windows) or Return (Mac OS).


Figure 6 Naming a new folder
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File naming conventions
How you name your files is important. Good file and folder names make developing your site easier (especially when 
you work with other people). They also help site visitors find your files. If you’re working with other people, it’s a 
good idea to discuss how you will name your files.


The following tips apply to all files used on the web—HTML files, image files, Flash movies, and so on.


Tip Reason Example


Give files unique, meaningful 
names.


Because you cannot put two files 
with the same name in one folder, 
all filenames need to be different. 
Use filenames that indicate the con-
tents of the files.


feedback_button.gif instead of 
button3.gif 


class-pet.jpg instead of roo-roo.jpg


Use meaningful folder names. Folders help you organize content. 
If their names are not meaningful, 
they will be less helpful.


images 
instead of 
folder_2


Use lowercase letters instead of 
uppercase (capital) letters.


Using a mix of uppercase and low-
ercase letters increases the possibil-
ity of broken links, because some 
web servers differentiate between 
upper and lowercase.


class_home.htm 
instead of Class_Picture.htm


Use file extensions (.htm, .gif, .jpg) 
consistently. Although you can use 
either .htm or .html, you should be 
consistent about using one or the 
other.


Using a mix of file extensions also 
increases the possibility of broken 
links.


index.htm and directions.htm
instead of index.html and direc-
tions.htm


If you’re working on a Macintosh 
computer, always include a file 
extension.


Although Windows requires file 
extensions, Macintosh does not. 
Web browsers need file extensions 
in order to display files.


index.htm instead of index


Use a hyphen (-) or an underscore    
( _ ) instead of a space.


Some web browsers do not recog-
nize spaces or convert them to other 
characters.


my-dog.gif or my_dog.gif 
instead of my dog.gif


Use letters and numbers. Many special symbols aren’t recog-
nized by web browsers or have spe-
cial meanings to web browsers.


my2friends.gif instead of 
me&friends.gif


Keep filenames as short as possible. Not only does this help prevent bro-
ken links, but some web servers will 
cut off names at 25 characters.


park_directions.htm instead of 
directions_to_the_fourth_street_pa
rk_plus_a_map.htm





		File naming conventions
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Student portfolios
The content and purpose of a portfolio can vary widely. Student portfolios typically contain examples of work as well 
as text descriptions and reflections on each piece. Three types of web portfolios showcase work, document progress 
through a project, or highlight skill growth. Examples of these three types follow.


Showcase portfolio


A showcase portfolio highlights its owner’s expertise by showing examples of best work. A student showcase would 
include a selection of finished images, designs, and websites. It might also provide a reflection in the piece or 
document of the process students followed to create it. Following is a sample category outline with associated files:


Image work


• Digital camera photographs


• Optimized images


Design work


• Logo


• Page banner


Client website (to be completed later)
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This is a sample flowchart for a showcase portfolio:
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Skill growth portfolio


A skill growth portfolio shows multiple samples of work in the same project to demonstrate increasing skill. For 
example, students include several versions of their page banners to show how the design evolved. This portfolio can 
also include reflection and discussion of redesigns. Following is a sample category outline with associated files:


Design work


Logo


• Logo (early version)


• Logo (final version)


• Logo self review


Page banner


• Page banner (early version)


• Page banner (final version)


• Page banner peer review


Interactive graphic (to be completed later)


Client site (to be completed later)


• Client site (early versions)


• Client site (final version)


• Client site reflections
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This is a sample flowchart for a skill growth portfolio:
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Project progress portfolio


A project progress portfolio contains a more complete selection of work around a particular project. The portfolio 
reflects the span of work done on a project—showing stages from early ideas to completion. An example would be to 
show all the work students did while learning about Adobe Fireworks CS5. The portfolio would include wireframes 
and storyboards, early versions, final versions, peer review, and self-review. For this portfolio type, students will need 
to scan worksheets and other handwritten documents to create web-ready versions.
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Cascading Style Sheets (CSS)
Before you learn about CSS, you should have a very basic understanding of HTML, the programming language used 
to create web pages.


The structure and appearance of a web page is controlled by its underlying code. The predominant programming 
language used to write this code for web pages is Hypertext Markup language, or HTML.


If you view the code for most web pages, you will see line after line of ordinary text, surrounded by short commands 
called HTML tags. These tags are placed in brackets before and after blocks of text and tell a web browser how to 
display or interact with information on a web page.  The example (Figure 1) shows two HTML tags that tell a web 
browser when a paragraph of text begins and ends. You will learn more about HTML tags in a later activity.


Figure 1 Sample HTML tags


When you create a web page by using Dreamweaver in Design view, the HTML code is created automatically.


Although HTML includes tags for displaying text, images, tables, and other page elements, it also has its limitations 
when it comes to precise page layout and formatting – a frustration for many designers. Cascading Style Sheets (CSS) 
are the answer to this problem.. CSS provides great control over the layout and design of web pages. Using CSS, you 
can format text, add margins, create columns, add borders to images, control the look and behavior of links, and much 
more.


If you have worked with styles in other programs, such as a word processor, you are already familiar with the basic 
function of CSS. In CSS, a style is simply a rule describing how to format content on a web page. A CSS (style sheet) 
is a collection of these rules.


Once you create a CSS rule and apply it to text or images, any changes to the style are reflected in your documents 
automatically. This can be a tremendous time saver and ensure consistency across your entire website.


Creating a new CSS


The most basic way to create CSS in Dreamweaver is to apply formatting by using the Property inspector. When you 
do, you are prompted to create a new CSS rule. You need to name the new rule and define the type of CSS.


There are three main types of CSS:


Class style: Similar to the styles you use in word processing and page layout programs. For example, you may want 
to format all body text in 10-point, Arial, dark green type. You can create a Class style with these attributes and then 
apply this style to all body text in your website.


Tag style: Applies global formatting to individual HTML tags rather than to individual selections. Suppose you want 
to modify the Heading 1 paragraph style to appear always in purple text. Instead of creating a class style and applying 
it to every heading in the document, you can create an HTML Tag style with these attributes and apply it to the 
Heading 1 <h1> tag. In effect, you are redefining the HTML tag.


ID style: A unique identifier (ID) for a style applied to headers, banners, menus, and other elements present in only 
one location in the document. Used once within a document or page.


In this guide, you use the Property inspector to create a simple CSS Class rule to format a block of text.


<p>This is a paragraph of text.</p>


Paragraph starting tag Paragraph ending tag
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To create a new CSS rule in the Property inspector:


1. Start Dreamweaver and open a new HTML document.


2. Add two short lines of text to the document.


To do this, type a line of text, press Enter (Windows) or 
Return (Mac OS) and type a second line of text.


3. Click to place the insertion point anywhere in the first 
line of text. (Do not highlight the text).


4. In the Property inspector, click CSS to change to the CSS 
formatting options (Figure 2).


5. Display the Font menu in the Property inspector 
(Figure 3), and select a font group.


The New CSS Rule dialog box appears (Figure 4).


Note: A good practice is to assign a font combination 
instead of a single font. This ensures that most page 
visitors will view page text the same way. A browser uses 
the first font in the combination that is installed in the 
visitor’s system. If none of the fonts in the combination is 
installed, the browser displays the text as specified by the 
visitor’s browser preferences. 


6. Display the Selector Type menu, and select Class (Can 
Apply To Any HTML Element) (Figure 5).


Figure 2 Property inspector


Figure 3 Font menu in the Property inspector


Figure 4 New CSS Rule dialog box


Figure 5 Selector type
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7. Click in the Selector Name box and type .mystyle 
(Figure 6).


Note: CSS rules must begin with a period and cannot 
contain spaces or special characters


8. Display the Rule Definition menu, and select (This 
Document Only) (Figure 7).


This tells Dreamweaver to create and store the CSS (style 
sheet) in the current document only. The new style will 
not be available for use in other documents.


To create a CSS for your entire website, you would 
choose (New Style Sheet File). This is discussed in a later 
activity.


9. Click OK.


The new font is applied to the first paragraph. The name 
of the style appears in the Targeted Rule box in the 
Property inspector.


Note: Because you didn’t highlight a specific word or 
character, you can continue to define this rule by 
applying additional formatting.


10. In the Property inspector, change the size to 18.


11. Click the Color box in the Property inspector and select a 
new color for the text.


The Property inspector shows the targeted rule (.mystyle) 
and its formatting  (Figure 8). The targeted rule is 
applied to the first paragraph (Figure 9).


You can use this CSS rule to format additional text in 
your document.


Figure 6 Selector Name


Figure 7 Rule Definition


Figure 8 Targeted rule in the Property inspector


Figure 9 Formatted text
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Applying CSS styles


After you create a CSS rule, you can use it to give your entire document or website a consistent appearance. You can 
apply a CSS rule to text by using the Property inspector.


To apply a CSS style:


1. Click anywhere in the second paragraph.


2. In the Property inspector, display the Targeted Rule 
menu, and select the CSS Class rule you just created 
(Figure 10).


The new style is applied to the second paragraph 
(Figure 11).


Note: If you edit the CSS style, both paragraphs will be 
updated automatically and consistently. You will learn 
more about creating and modifying CSS in a later 
activity.


Figure 10 Targeted Rule menu


Figure 11 CSS style applied to both paragraphs
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Usability


Student name:_________________________________________________ Date: ________________________


URL: ________________________________________________________________________________________


Site name: ____________________________________________________________________________________


What types of navigation elements are used: buttons, hyperlinks, images, something else? One type or several? 
Describe each type of navigation element.


As you navigate, how many clicks does it generally take to get to information you are seeking?


As you navigate, do you get to the information you are expecting?
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Is the site structure apparent?


How long does it take for pages to load?


Is the text readable? Is the text uniquely styled? If so, does the styling add value to the purpose?


What are the elements of the visual layout? How do these elements make it easier or more difficult for visitors?
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Are there clear titles, headings, or other visual elements that specifically help organize the information?





		Usability
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How to wireframe a home page
The home page wireframe includes a design layout (graphics, text, and site navigation scheme) to make creating the 
home page easier. Use the following guidelines to help you create the wireframe of your home page by using Adobe 
Fireworks CS5.


Graphics


Draw rectangles on the page to indicate the size and placement of graphics. Label these rectangles with the filenames 
of the graphics they represent..


• What graphics will you include on the home page?


• Where will you place the graphics on the page?


Text


Draw rectangles on the page to indicate the text placement. Label these rectangles with content descriptions.


• What text will you include on the home page?


• Where will you place text on the page?


Navigation


Draw a rectangle to indicate the placement of the links to other pages. Label this rectangle with the names of the other 
pages. (You will build graphical buttons for these links later in this course.)


• According to your flowchart, the home page directly links to what pages (what are the menu items)?


• Where will you place these links on your home page?


Color


Fill in the background of the wireframe with your desired color and create sets of sample text that show the different 
text colors you plan to use on your home page.
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Creating a wireframe with Adobe Fireworks CS5


Wireframes are basic sketches of your web documents that you can use to organize page elements—and get feedback 
from your clients—before you add content to the page. In the following steps, you will first import a scanned sketch 
of your home page, then use Fireworks to create a wireframe based on this sketch.


To create a wireframe in Fireworks:


1. Using pen and paper, sketch your home page. Include all 
major components, such as navigation, content areas, 
titles, and logos.


2. Scan the sketch into your computer. 


For information on scanning, please see the Unit 1 guide 
“How to scan images without image-editing software."


3. Start Fireworks and create a new document  1024 pixels 
wide and 640 pixels high.


Note: These dimensions are those of a standard web 
page.


4. Open the Layers panel, and create or rename two layers: 


• Wireframe


• Wireframe Sketch


Make sure the Wireframe Sketch layer is below the 
Wireframe layer (Figure 1).


5. With the Wireframe Sketch layer selected, choose File > 
Import.


The Import dialog box opens.


6. Select the file you scanned in step 2, and click Import 
(Windows) or Open (Mac OS).


7. Click  in the upper-left corner of the canvas to place the 
sketch.


8. Click the imported sketch to select it.


9. Select  Modify > Canvas > Image Size.


The Image Size dialog box opens (Figure 2). 


10. Make sure the Contstrain Proportions option is selected.


11. Make sure that Pixels is selexted for Horizontal Pixel 
Dimensions.


12. In the Horizontal Pixel Dimensions text boxes, type 
1024.


13. Click OK.


The image resizes to the canvas width.


Figure 1 Wireframe and Wireframe Sketch layers 
added to the Layers panel


Figure 2 Image Size dialog box


Horizontal Pixel Dimentsions text box


Constrain Proportions option
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14. Select Window > Align to open the Align panel 
(Figure 3) and take the following steps:


a. Click the Relative To Canvas button.


b. Click the Align Horizontal Center button.


c. Click the Align Top Edge button.


15. In the Layers panel, lock the Wireframe Sketch layer.


16. Select the Wireframe layer.


17. Make sure rulers and guides are visible. If not, select 
View > Rulers and View > Guides > Show Guides.


18. Drag guides to the edges of each page element 
(Figure 4).


Note: In the example, guide color has been changed to 
dark blue so that guides are more visible against the 
background. You can change guide colors by selecting 
Edit > Preferences (Windows) or Fireworks > 
Preferences (Mac OS).


19. Select View > Guides > Lock Guides.


Locking the guides will make them easier to use.


20. Select View > Guides > Snap To Guides.


21. Select the Rectangle tool.


22. In the Property inspector, make the following changes 
(Figure 5):


a. Select None from the Fill pop-up menu.


b. Select Basic > Soft Line from the Stroke pop-up 
menu.


c. Set Stroke color to dark grey.


d. Set Stroke width to 2 pixels.


23. Using the guides, draw rectangles around all major page 
elements (Figure 6).


24. Once you are satisfied with the position of the rectangles, 
make the Wireframe Sketch layer invisible.


25. Choose View > Guides > Show Guides to hide guides.


Figure 3 Align panel


Figure 4 Imported sketch with guides added


Figure 5 Rectangle Property inspector


Figure 6 Rectangles drawn around page elenents


Align Horizontal 
Center button


Align Top 
Edge button


Relative To 
Canvas button







Activity 2.5 guide Adobe Fireworks CS5


4 How to wireframe a home page © 2010 Adobe Systems Incorporated


26. Using the Text tool, label each element to complete the 
wireframe (Figure 7).


27. Select File > Save As and save the file as a PNG.


Figure 7 Completed wireframe
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How to work with text and images
Text and images are the basic elements of almost every website. You add text just as you would in a word processing 
program, and you add images by inserting them from an existing file. Arranging text and images on a web page 
requires knowledge of Cascading Style Sheets (CSS) or the use of tables, which are both covered in later activities.


In this activity, you create a simple web page by entering text, applying basic paragraph formatting, and adding an 
image to the page.


Adding text to a document


You add text by using the keyboard or by pasting from another document. You modify text by using the Property 
inspector. 


To add text:


1. Start Dreamweaver.


2. Click HTML to create a new document (Figure 1).


The flashing insertion point is located at the top of the 
new document.


Note: In an existing document, you can click to place the 
insertion point where you want new text to begin.


3. Type some text or paste text copied in another 
application.


Make sure the Property inspector is open and the HTML 
option is selected. It is docked at the bottom of the 
screen. If the Property inspector is not open, select 
Window > Properties.


When you first begin typing, there is no paragraph 
formatting applied to the text, as shown by the word 
None in the Format menu in the Property inspector 
(Figure 2).  


4. Press Enter (Windows) or Return (Mac OS) to begin a 
new paragraph.


Dreamweaver applies the default Paragraph style to your 
text, as shown in the Property inspector (Figure 3).


Note: Web browsers automatically insert a blank line of 
space between paragraphs. You can start a new line 
without this space by inserting a line break: Press 
Shift+Enter (Windows) or Shift+Return (Mac OS).


Figure 1 Create New HTML document


Figure 2 HTML options in the Property inspector


Figure 3 Paragraph format
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Applying basic HTML formatting to paragraphs and text


To apply simple formatting, such as bold and italics, or to link text to another web page, you can use the HTML 
options in the Property inspector.


To apply basic HTML formatting to paragraphs and text:


1. Click to place the insertion point anywhere in the line of 
text you added to the page.


2. In the Property inspector, select Heading 1 in the Format 
menu.


The entire paragraph is formatted to the built-in Heading 
1 paragraph style.


3. Double-click a single word to select it, or drag to 
highlight several words.


4. In the Property inspector, click the Italic button 
(Figure 4).


The selected text is now italic.


Note: You will learn to apply additional text formatting, 
such as size and color, in a later activity.


Figure 4 HTML paragraph/text properties


Linking text to other pages, web sites, and e-mail addresses


Using the HTML options in the Property inspector, you can link text to other documents within your site or to other 
web sites. You can also create an e-mail link. When a user clicks an e-mail link, a new mail message opens in the 
user’s default mail program. The message is addressed automatically to the e-mail address you specify.


Since this is a new site with only one page, you will create an e-mail link.


To link text to an e-mail address:


1. Select the text you want to represent the link.


2. In the Property inspector, click in the Link box and type 
mailto:myaddress@domain.com (or .net, .org, and so 
on) (Figure 5), and press Enter (Windows) or Return 
(Mac OS).


The selected text is now formatted as a link, as indicated 
by the default blue underline (Figure 6).


Note: To link text to another document, enter the path to 
the document in the Link box. You will learn more about 
creating links in a later activity.


Figure 5 E-mail link


Figure 6 Linked text


Bold Italic Unordered list Ordered list


Text indent


Text Outdent
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Adding images


You can insert any image into a web page, as long as it is accessible to Dreamweaver and in a web format. Most 
images in web pages are either GIFs or JPEGs.


To add an image:


1. Open a document in Dreamweaver.


2. Make sure the document is saved in your site’s local 
folder.


3. Position the insertion point where you want to add an 
image.


4. Select Insert > Image.


The Select Image Source dialog box opens (Figure 7).


5. Browse to the folder with the desired image.


6. Select the desired image.


A preview of the image appears in the right side of the 
dialog box (Windows).


7. Click OK (Windows) or Choose (Mac OS).


If the image is not in your site folder, Dreamweaver asks 
if you want to copy the file there (Figure 8). If the image 
is already stored in your site, you can skip steps 8 and 9.


8. Click Yes.


The Copy File As dialog box appears (Figure 9). By 
default the image will be copied to the root folder of your 
site. You can store the image in the root folder, or place 
the image in a subfolder of your site.


9. Browse to a folder in your site where you want to store 
the file, and click Save.


The Image Tag Accessibility Attributes dialog box opens 
(Figure 10). This dialog box lets you add a description to 
the image so that screen readers can interpret it.


10. Enter a brief description. You can also provide a link to a 
file with a longer description.


11. Click OK.


The image is added to your document.


Figure 7 Select Image Source dialog box


Figure 8 File outside of root folder warning 
message


Figure 9 Copy File As dialog box


Figure 10 Image Tag Accessibility Attributes 
dialog box
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Resizing images


You can resize an image by clicking on it and dragging selection handles.


Note: Changing the width or height of your image in Dreamweaver can reduce the image quality. It is better practice 
to resize an image in an image-edited program such as Adobe Fireworks CS5 or Adobe Photoshop CS5 before 
importing it into Dreamweaver.


To resize an image in Dreamweaver:


1. Select the image.


Selection handles appear on the right and bottom edges of the image (Figure 11).


2. Do one of the following.


• To resize the image horizontally, drag the selection handle on the right.


• To resize the image vertically, drag the selection handle on the bottom.


• To resize in both directions at the same time, drag the selection handle at the lower-right corner. To retain the 
relative proportion of height and width, hold down Shift as you drag.


Figure 11 Image with selection handles


Selection handles
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